Found a Penthouse Vault Bug

I noticed this the other day when depositing chips into my vault.


I deposited 300K and magically lost 1600 chips. Makes me wonder how often this has happened since I dont typically pay the much attention to my chip count.

Also had this happen:


Won the bonus round but could get the bonus round to start no matter what button I pressed.
A little on the frustrating side

DL_David

Administrator

Bloodsabbath68 wrote

I deposited 300K and magically lost 1600 chips.

We did find a problem with the code that can cause the number of chips that you see in the game to be different from the number of chips recorded for your account on the server.  With this bug it will count bonus chips twice on the PS4 (incorrectly) and once on the server (correct).  So in this case you may have earned a 1,600 chip bonus and been credited with 3,200 chips in the game.

When you use the safe it resyncs your chip count with the server so the numbers become correct again.  This would also be the case if you quit the game and restarted.

We've fixed the problem in the next update.

Charlie Mac

Member

Bloodsabbath68 wrote

I noticed this the other day when depositing chips into my vault.


I deposited 300K and magically lost 1600 chips. Makes me wonder how often this has happened since I dont typically pay the much attention to my chip count.

Also had this happen:


Won the bonus round but could get the bonus round to start no matter what button I pressed.
A little on the frustrating side

i now feel less paranoid for not using that vault.


“Trust but, verify”

DL_David wrote
Bloodsabbath68 wrote

I deposited 300K and magically lost 1600 chips.

We did find a problem with the code that can cause the number of chips that you see in the game to be different from the number of chips recorded for your account on the server.  With this bug it will count bonus chips twice on the PS4 (incorrectly) and once on the server (correct).  So in this case you may have earned a 1,600 chip bonus and been credited with 3,200 chips in the game.

When you use the safe it resyncs your chip count with the server so the numbers become correct again.  This would also be the case if you quit the game and restarted.

We've fixed the problem in the next update.

I see, thanks for the clarification