Connectivity Issues

LV_Jag

Member

Haven't had any disconnection issues today, September 10th.

SoCalKingg

New member

Why has this game stopped working on PS4 ever since I updated it?  I have a FIOS connection, but the game will not load.  I have tried 100x to get into it since the update and I never get past the home screen.  Either the chip just stays spinning non-stop in the corner or it tells me there is an error connecting to the server.  I never had the issue once prior to the update and now I can't get in at all.  Is this going to be fixed or should I just delete the game?

DL_David

Administrator

You might want to check if your router or ISP have a firewall that is blocking UDP packets.  This would block all communications with our servers.

ideacipher

New member

Update: It's working now. All I did was read the Terms or Use all the way through and and then tried again....
I thought I had already did that last year but what ever it works now.

OLD{

DL_David wrote

You might want to check if your router or ISP have a firewall that is blocking UDP packets.  This would block all communications with our servers.

I also have the issue of the spinning chip after installing the forced update. My router doesn't block UDP packets. At this point it looks like a uninstall/reinstall unless I can get a working patch for the latest update.

I'm running Four Kings Casino and Slots V1.38
PS4 system software V7.55
}

Last edited by ideacipher (11 Sep 2020 03:20)

Pazuzu98224

New member

Since the update to 1.38 on the Playstation 4 I cannot get into the game at all. It leaves the title screen, loads about half way and then kicks me back to the main menu with error 1015. This is incredibly frustrating since I basically login every single day for the various tasks and now I am missing all of those things.

Supernova

Member

David there are people across the casino in every differant areas high rollers VIP poker bingo blackjack the lobby all losing connection during play , losing valuable RP chips etc ...... And plenty that just cannot get in 4k at all

Last edited by Supernova (11 Sep 2020 13:28)

DL_David

Administrator

So this is the lowdown: we've moved from TCP to UDP.  We had moved to UDP on PC 9 months ago and Switch has been on UDP since release (4 months) and don't have any on-going problems on those platforms. We were hesitant to move PS4 because we knew there would be some distruption -- better for some, worse for others -- but given the networking challenges we've had over the past week or two we felt it was time. 

The advantage with UDP is that it is more flexible: where TCP will break, UDP will bend.  We're able to better control the retry attempts when packets aren't getting through to our servers. When you see the orange internet indicator while playing, it means the packets are not getting through to the server (or the server packets are not getting through to your system). We have a 30 second timeout to continue retrying and during this time the PS4 code has probably tried 6 - 8 times to try to get through to our server without hearing anything back.  At some point our code has to give up because you're getting too far behind the events going on in the room you're in (and the packets to be sent and received are piling up).

So you might have gigabit internet but if there's a blip and there's 30 seconds where packets can't get through then Four Kings is going to disconnect (we experience this in our office every so often).

Our servers are always up.  If we get a 30 second disconnection then we lose all the players in the game.  So we know when our server's internet connection is the cause of the problems and this is not what has been happening over the past two weeks.

If you are having connection problems and have access to another internet feed (your phone, a friend's house) then this is a good test to see if your internet is causing the problem.  Also, there may be some issues with UDP (your router/ISP) that weren't there for TCP.

So as for the past couple of weeks (since version 1.37) it seems that our server code is requiring more server processor time... we're still not sure why... but this kicked up a number of problems including random disconnections when connecting/changing rooms and seats becoming permanently unusable. We fixed this as best we could by better error handling on the server side and then we ultimately moved to a server with more processor power and that seems to largely have solved the problem, although there's still more work to be done.

Having done that we felt it was time to move to UDP for the reasons above. So at this point we're not prepared to point the finger at your internet with 100% certainty and say that's the problem but we're probably in the 60% - 70% range.  There are other channels in between your system and our servers including your ISP and our upstream providers.  We're going to continue to look (as best we can) to determine if there are any issues there. 

For the sake of testing, last night we ran an endurance test on one of our dev PS4s -- started it at end of day, had it jump from room to room and it was still running when we came in this morning. Frankly, we kind of expect our office internet to maybe have a blip and cause a disconnection but we got 15 hours straight of heavy-use connection. So we're fairly sure the client/server code is generally working pretty well but we understand that there are edge cases and internet issues that can throw things off.

We also have live usage monitors for Four Kings and we can generally see when something goes wrong (and things do go wrong) or when large numbers of players are struggling with connecting but by and large the concurrent player numbers are pretty much in line with historic graphs. 

So the bottom line is the we're pretty comfortable, but not 100% comfortable, with where things now are but we're watching closely and looking for any problem areas.

Charlie Mac

Member

So, basically the game is permanently broken unless i play in your office and your " comfortable " with it ? What a bunch of bullshit. If I understand you correctly the game is now designed to operate with zero packet loss which even with my wired gigabyte internet is an impossible feat. I've experienced more disconnections in the last two weeks than in the last 5 years and I'm not  " comfortable " with it.


“Trust but, verify”

Four Kings is right. It's all our fault for continuing to try and play this broken game. I've seen others and personally been dropped from playing several times every day in the last two weeks. Sometimes I can't even get logged in to be dropped. This didn't happen to me until after they installed the "update" to change the start up screen and nobility. But according to them it's my top of the line high speed optic internet's fault. Even though this game is the ONLY internet issue I have. Nice try Four Kings. But your BS blame and excuses are not working, and neither is your game. I hope everyone quits playing.

GamblingGirl

Member

DOESNT WORK!!!!!!! Sick of getting your internet is slowing 4 kings exclamation mark in the corner and then booted. This is the only game booting and freezing out of the 57 games I own, so it's not me!

Supernova

Member

Can't get through a game of bingo without getting kicked so couldn't complete today's tasks played this game years never known it too be so bad

LV_Jag

Member

I'm wondering if those still getting kicked need to get a new router.  I'm not saying that's the issue for everyone here.  Ever since they sent out the patch, I was only kicked once.  It's been a week now and there haven't been any disconnects for me in the game.  My router is new-ish.  It's about a year old now, but I know the connection was awful in my other games before upgrading, including Four Kings.

GamblingGirl

Member

LV_Jag wrote

I'm wondering if those still getting kicked need to get a new router.  I'm not saying that's the issue for everyone here.  Ever since they sent out the patch, I was only kicked once.  It's been a week now and there haven't been any disconnects for me in the game.  My router is new-ish.  It's about a year old now, but I know the connection was awful in my other games before upgrading, including Four Kings.


I'm direct, hardwired, not through a router so there's that mystery solved.

DL_Paul

Administrator

If you're hardwired, then you're running an ethernet cable directly to your service providers modem, which acts as a router. You may want to confirm that the firmware on that unit is fully up-to-date if possible. We continue to monitor disconnections and since the most recent patch we've noticed much improved stability among the general userbase. We plan to issue another patch in a couple weeks which will have additional fixes based on the data we've received.

LV_Jag

Member

I've been having a lot of disconnection issues again.  Just had one at 10:14am CST today.  Yesterday, was disconnected at 3pm CST.  I'm sure I'll be booted at least one more time throughout the day.  My typical game play has me in bingo for progressives.  It's annoying getting kicked mid-game and have to load back in and get caught up on numbers.

GamblingGirl

Member

DL_Paul wrote

If you're hardwired, then you're running an ethernet cable directly to your service providers modem, which acts as a router. You may want to confirm that the firmware on that unit is fully up-to-date if possible. We continue to monitor disconnections and since the most recent patch we've noticed much improved stability among the general userbase. We plan to issue another patch in a couple weeks which will have additional fixes based on the data we've received.


It's not ME, it's you guys. Quit blaming us for whatever it is screwing up the game. The game lags, the slots lag, I get kicked from bingo, I get exclamation marks every day on here now. Your game crams so much junk that's unnecessary into it, like dealers, too many blinking lights and noises, it makes it lag more.

DL_Paul

Administrator

I wasn't blaming, I was just trying to provide assistance as to what your specific issue may be. We'll be issuing another update that will provide additional connectivity fixes. Hopefully those will add the stability to correct the issues you're experiencing.

GamblingGirl

Member

DL_Paul wrote

I wasn't blaming, I was just trying to provide assistance as to what your specific issue may be. We'll be issuing another update that will provide additional connectivity fixes. Hopefully those will add the stability to correct the issues you're experiencing.


I'm done being crabby now, I think I got that all out of my system.
Hoping the fix works and doesn't break other stuff.

LV_Jag

Member

ETA on update to help with the constant disconnects?  Was disconnected during my second game of bingo this evening.  Didn't even have the option to sit back at my seat after reloading back in.  Chip refund requested, but this is getting so frustrating.  sad

Molgulax

New member

Hi
Been trying to start Four kings Casino for about 12 hours now, but it will not start. I am on PS4. I start by clicking the ikon, then the image of the fountain appears, but there is no "press the X" button to start the game. Are the servers down? . I keep getting the following error message:

"Unable to connect to the server. Please visit the Community Forums to confirm server status. Note that some firewalls can interfere with communications to our server. Try temporary disabling it and try logging in again. (1019)"

I have done all above, but still nothing works.

Last edited by Molgulax (29 Sep 2020 04:03)

People are getting tired of being dropped from playing games, or unable to even get logged in to play. I don't know what you guys did when you changed the startup screen but it was an epic failure. Did you switch to cheaper servers? It is not the hundreds of player's internet connections or firewalls that is failing, this disaster is all on Four Kings. I used to witness a few people being booted from games but now it's very common to see several people booted every few minutes. Truly sad.

DL_Jared

Administrator

The newest update includes additional networking stability fixes based on the data we've received. Please let us know how things go for you once you've installed today's update.

Same old stuff. I witnessed about a dozen players getting booted today and then it happened to me. Four Kings is the ONLY GAME that I see this happening. Something is still very wrong. It's nice we can request chip refunds, but this is getting ridiculous. And to think I just spent real money on chips yesterday. Never again. You will never see another penny of real money from me unless you fix this mess.

Charlie Mac

Member

Was good for a solid week or so but, now back to the same old shit.


“Trust but, verify”

Supernova

Member

Yes found myself getting kicked during a bonus round on slots winnings was upto 500k plus and got the connection triangle and kicked off ... Along with lots of others, wasn't given a chip refund as per ....
. Pfft